<!DOCTYPE html>
<html lang="en">

<head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <title>When algorithms surprise us - AI WeirdnessCommentShareCommentShare</title>
    <link rel="stylesheet" href="/assets/built/screen.css?v=cd27d1f60a">
    <link rel="preconnect" href="https://fonts.gstatic.com">
    <link rel="stylesheet" href="https://fonts.googleapis.com/css2?family=Mulish:ital,wght@0,400;0,700;0,800;1,400;1,700&display=swap">

    <script>
        var siteUrl = 'https://www.aiweirdness.com';
    </script>

    <script>
        var localTheme = localStorage.getItem('dawn_theme');
        switch (localTheme) {
            case 'dark':
                document.documentElement.classList.add('theme-dark');
                break;
            case 'light':
                document.documentElement.classList.add('theme-light');
                break;
            default:
                break;
        }
    </script>

    <meta name="description" content="Machine learning algorithms are not like other computer programs. In the usual sort of programming, a human programmer tells the computer exactly what to do. In machine learning, the human programmer merely gives the algorithm the problem to be solved, and through trial-and-error the algorithm has to figure out how to solve it." />
    <link rel="icon" href="/favicon.png" type="image/png" />
    <link rel="canonical" href="https://www.aiweirdness.com/when-algorithms-surprise-us-18-04-13/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    <link rel="amphtml" href="https://www.aiweirdness.com/when-algorithms-surprise-us-18-04-13/amp/" />
    
    <meta property="og:site_name" content="AI Weirdness" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="When algorithms surprise us" />
    <meta property="og:description" content="Machine learning algorithms are not like other computer programs. In the usual sort of programming, a human programmer tells the computer exactly what to do. In machine learning, the human programmer merely gives the algorithm the problem to be solved, and through trial-and-error the algorithm has to figure out how to solve it." />
    <meta property="og:url" content="https://www.aiweirdness.com/when-algorithms-surprise-us-18-04-13/" />
    <meta property="og:image" content="https://www.aiweirdness.com/content/images/image/fetch/w_1200-c_limit-f_jpg-q_auto:good-fl_progressive:steep/https-3A-2F-2Fbucketeer-e05bbc84-baa3-437e-9518-adb32be77984.s3.amazonaws.com-2Fpublic-2Fimages-2F25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364" />
    <meta property="article:published_time" content="2018-04-13T17:59:00.000Z" />
    <meta property="article:modified_time" content="2021-05-31T15:28:02.000Z" />
    <meta property="article:tag" content="machine learning" />
    <meta property="article:tag" content="evolutionary algorithms" />
    <meta property="article:tag" content="evolution" />
    <meta property="article:tag" content="neural networks" />
    <meta property="article:tag" content="the matrix" />
    
    <meta property="article:publisher" content="https://www.facebook.com/ghost" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="When algorithms surprise us - AI WeirdnessCommentShareCommentShare" />
    <meta name="twitter:description" content="Machine learning algorithms are not like other computer programs. In the usual sort of programming, a human programmer tells the computer exactly what to do. In machine learning, the human programmer merely gives the algorithm the problem to be solved, and through trial-and-error the algorithm has to figure out how to solve it." />
    <meta name="twitter:url" content="https://www.aiweirdness.com/when-algorithms-surprise-us-18-04-13/" />
    <meta name="twitter:image" content="https://www.aiweirdness.com/content/images/image/fetch/w_1200-c_limit-f_jpg-q_auto:good-fl_progressive:steep/https-3A-2F-2Fbucketeer-e05bbc84-baa3-437e-9518-adb32be77984.s3.amazonaws.com-2Fpublic-2Fimages-2F25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Janelle Shane" />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="machine learning, evolutionary algorithms, evolution, neural networks, the matrix" />
    <meta name="twitter:site" content="@ghost" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "AI Weirdness",
        "url": "https://www.aiweirdness.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.aiweirdness.com/content/images/2021/03/ai_weirdness_with_neural_net_box.png"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Janelle Shane",
        "image": {
            "@type": "ImageObject",
            "url": "https://www.aiweirdness.com/content/images/2021/03/neural_net_box_default_square-01.png",
            "width": 1667,
            "height": 1667
        },
        "url": "https://www.aiweirdness.com/author/ai/",
        "sameAs": [
            "http://www.janelleshane.com"
        ]
    },
    "headline": "When algorithms surprise us - AI WeirdnessCommentShareCommentShare",
    "url": "https://www.aiweirdness.com/when-algorithms-surprise-us-18-04-13/",
    "datePublished": "2018-04-13T17:59:00.000Z",
    "dateModified": "2021-05-31T15:28:02.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://www.aiweirdness.com/content/images/image/fetch/w_1200-c_limit-f_jpg-q_auto:good-fl_progressive:steep/https-3A-2F-2Fbucketeer-e05bbc84-baa3-437e-9518-adb32be77984.s3.amazonaws.com-2Fpublic-2Fimages-2F25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364"
    },
    "keywords": "machine learning, evolutionary algorithms, evolution, neural networks, the matrix",
    "description": "Machine learning algorithms are not like other computer programs. In the usual\nsort of programming, a human programmer tells the computer exactly what to do.\nIn machine learning, the human programmer merely gives the algorithm the problem\nto be solved, and through trial-and-error the algorithm has to figure out how to\nsolve it.\n\nThis often works really well - machine learning algorithms are widely used for\nfacial recognition, language translation, financial modeling, image recognition,\nand ad de",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://www.aiweirdness.com/"
    }
}
    </script>

    <meta name="generator" content="Ghost 4.12" />
    <link rel="alternate" type="application/rss+xml" title="AI Weirdness" href="https://www.aiweirdness.com/rss/" />
    <script defer src="https://unpkg.com/@tryghost/portal@~1.8.0/umd/portal.min.js" data-ghost="https://www.aiweirdness.com/" crossorigin="anonymous"></script><style id="gh-members-styles">.gh-post-upgrade-cta-content,
.gh-post-upgrade-cta {
    display: flex;
    flex-direction: column;
    align-items: center;
    font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen, Ubuntu, Cantarell, 'Open Sans', 'Helvetica Neue', sans-serif;
    text-align: center;
    width: 100%;
    color: #ffffff;
    font-size: 16px;
}

.gh-post-upgrade-cta-content {
    border-radius: 8px;
    padding: 40px 4vw;
}

.gh-post-upgrade-cta h2 {
    color: #ffffff;
    font-size: 28px;
    letter-spacing: -0.2px;
    margin: 0;
    padding: 0;
}

.gh-post-upgrade-cta p {
    margin: 20px 0 0;
    padding: 0;
}

.gh-post-upgrade-cta small {
    font-size: 16px;
    letter-spacing: -0.2px;
}

.gh-post-upgrade-cta a {
    color: #ffffff;
    cursor: pointer;
    font-weight: 500;
    box-shadow: none;
    text-decoration: underline;
}

.gh-post-upgrade-cta a:hover {
    color: #ffffff;
    opacity: 0.8;
    box-shadow: none;
    text-decoration: underline;
}

.gh-post-upgrade-cta a.gh-btn {
    display: block;
    background: #ffffff;
    text-decoration: none;
    margin: 28px 0 0;
    padding: 8px 18px;
    border-radius: 4px;
    font-size: 16px;
    font-weight: 600;
}

.gh-post-upgrade-cta a.gh-btn:hover {
    opacity: 0.92;
}</style><script async src="https://js.stripe.com/v3/"></script>
    <!-- Enables indexed search in Dawn. By default will enable content search. If too slow, this can be disabled.
!-->
<script>
    var gh_search_key = '50ffc4acd2930eaf4e3ee86b2a';
    var gh_search_migration = 'v1';
</script>

<!-- Custom blockquotes for AI-generated text
!-->
<style>
	blockquote{
  		font-size: 1.0em;
  		width:90%;
  		margin:10px auto;
  		font-style: normal;
        font-weight: normal;
  		color: #000000;
        text-align: left;
  		padding:0.5em 30px 0.5em 20px;
  		border-left:4px solid #00b31e;
  		line-height:1.0;
 		position: relative;
  		background:#FFFFFF !important;
}
</style><style>:root {--ghost-accent-color: #00b31e;}</style>
</head>

<body class="post-template tag-machine-learning tag-evolutionary-algorithms tag-evolution tag-neural-networks tag-the-matrix tag-hash-tumblr tag-hash-substacktumblrduplicate">
    <svg width="0" height="0" style="display: none;">
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="arrow-left">
        <path d="M26.667 14.667v2.667h-16L18 24.667l-1.893 1.893L5.547 16l10.56-10.56L18 7.333l-7.333 7.333h16z"></path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="arrow-right">
        <path d="M5.333 14.667v2.667h16L14 24.667l1.893 1.893L26.453 16 15.893 5.44 14 7.333l7.333 7.333h-16z"></path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="brightness-2">
        <path
            d="M13.333 2.667c-2.427 0-4.707.667-6.667 1.8 4 2.307 6.667 6.6 6.667 11.533s-2.667 9.227-6.667 11.533c1.96 1.133 4.24 1.8 6.667 1.8 7.36 0 13.333-5.973 13.333-13.333S20.693 2.667 13.333 2.667z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="chevron-left">
        <path d="M20.547 22.107L14.44 16l6.107-6.12L18.667 8l-8 8 8 8 1.88-1.893z"></path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="chevron-right">
        <path d="M11.453 22.107L17.56 16l-6.107-6.12L13.333 8l8 8-8 8-1.88-1.893z"></path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="circle-half-full">
        <path
            d="M16 2.667c-7.36 0-13.333 5.973-13.333 13.333s5.973 13.333 13.333 13.333c7.36 0 13.333-5.973 13.333-13.333s-5.973-13.333-13.333-13.333zM16 5.333c5.893 0 10.667 4.773 10.667 10.667s-4.773 10.667-10.667 10.667v-21.333z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="dots-horizontal">
        <path
            d="M21.333 16c0-1.473 1.194-2.667 2.667-2.667v0c1.473 0 2.667 1.194 2.667 2.667v0c0 1.473-1.194 2.667-2.667 2.667v0c-1.473 0-2.667-1.194-2.667-2.667v0zM13.333 16c0-1.473 1.194-2.667 2.667-2.667v0c1.473 0 2.667 1.194 2.667 2.667v0c0 1.473-1.194 2.667-2.667 2.667v0c-1.473 0-2.667-1.194-2.667-2.667v0zM5.333 16c0-1.473 1.194-2.667 2.667-2.667v0c1.473 0 2.667 1.194 2.667 2.667v0c0 1.473-1.194 2.667-2.667 2.667v0c-1.473 0-2.667-1.194-2.667-2.667v0z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="facebook-box">
        <path
            d="M6.667 4h18.667c1.467 0 2.667 1.2 2.667 2.667v18.667c0 1.467-1.2 2.667-2.667 2.667H6.667A2.675 2.675 0 0 1 4 25.334V6.667C4 5.2 5.2 4 6.667 4zM24 6.667h-3.333A4.672 4.672 0 0 0 16 11.334v3.333h-2.667v4H16V28h4v-9.333h4v-4h-4V12c0-.733.6-1.333 1.333-1.333H24v-4z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="facebook">
        <path
            d="M22.667 2.667V8H20c-.92 0-1.333 1.08-1.333 2v3.333h4v5.333h-4v10.667h-5.333V18.666h-4v-5.333h4V8a5.332 5.332 0 0 1 5.333-5.333h4z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="linkedin">
        <path
            d="M25.333 4c1.473 0 2.667 1.194 2.667 2.667v0 18.667c0 1.473-1.194 2.667-2.667 2.667v0h-18.667c-1.473 0-2.667-1.194-2.667-2.667v0-18.667c0-1.473 1.194-2.667 2.667-2.667v0h18.667zM24.667 24.667v-7.067c0-2.401-1.946-4.347-4.347-4.347v0c-1.133 0-2.453 0.693-3.093 1.733v-1.48h-3.72v11.16h3.72v-6.573c0-1.027 0.827-1.867 1.853-1.867 1.031 0 1.867 0.836 1.867 1.867v0 6.573h3.72zM9.173 11.413c1.237 0 2.24-1.003 2.24-2.24v0c0-1.24-1-2.253-2.24-2.253-1.244 0-2.253 1.009-2.253 2.253v0c0 1.24 1.013 2.24 2.253 2.24zM11.027 24.667v-11.16h-3.693v11.16h3.693z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 40 40" id="loader">
        <path opacity="0.3" fill="currentColor"
            d="M20.201,5.169c-8.254,0-14.946,6.692-14.946,14.946c0,8.255,6.692,14.946,14.946,14.946 s14.946-6.691,14.946-14.946C35.146,11.861,28.455,5.169,20.201,5.169z M20.201,31.749c-6.425,0-11.634-5.208-11.634-11.634 c0-6.425,5.209-11.634,11.634-11.634c6.425,0,11.633,5.209,11.633,11.634C31.834,26.541,26.626,31.749,20.201,31.749z" />
        <path fill="currentColor"
            d="M26.013,10.047l1.654-2.866c-2.198-1.272-4.743-2.012-7.466-2.012h0v3.312h0 C22.32,8.481,24.301,9.057,26.013,10.047z">
            <animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 20 20" to="360 20 20"
                dur="0.5s" repeatCount="indefinite" />
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="magnify">
        <path
            d="M12.667 4a8.667 8.667 0 0 1 8.667 8.667c0 2.147-.787 4.12-2.08 5.64l.36.36h1.053l6.667 6.667-2 2-6.667-6.667v-1.053l-.36-.36a8.689 8.689 0 0 1-5.64 2.08C7.88 21.334 4 17.454 4 12.667S7.88 4 12.667 4zm0 2.667c-3.333 0-6 2.667-6 6s2.667 6 6 6 6-2.667 6-6-2.667-6-6-6z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="menu-down">
        <path d="M9.333 13.333L16 20l6.667-6.667H9.334z"></path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="rss-box">
        <path
            d="M6.667 4h18.667c1.467 0 2.667 1.2 2.667 2.667v18.667c0 1.467-1.2 2.667-2.667 2.667H6.667A2.675 2.675 0 0 1 4 25.334V6.667C4 5.2 5.2 4 6.667 4zM10 20c-1.107 0-2 .893-2 2s.893 2 2 2 2-.893 2-2-.893-2-2-2zm-2-6.667V16c4.413 0 8 3.587 8 8h2.667c0-5.893-4.773-10.667-10.667-10.667zM8 8v2.667c7.36 0 13.333 5.973 13.333 13.333H24c0-8.84-7.16-16-16-16z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="star">
        <path
            d="M16 23.027L24.24 28l-2.187-9.373 7.28-6.307-9.587-.827-3.747-8.827-3.747 8.827-9.587.827 7.267 6.307L7.759 28l8.24-4.973z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" id="table-of-contents">
        <path d="M3 9h14V7H3v2m0 4h14v-2H3v2m0 4h14v-2H3v2m16 0h2v-2h-2v2m0-10v2h2V7h-2m0 6h2v-2h-2v2z"></path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="twitter-box">
        <path
            d="M6.667 4h18.667c1.467 0 2.667 1.2 2.667 2.667v18.667c0 1.467-1.2 2.667-2.667 2.667H6.667A2.675 2.675 0 0 1 4 25.334V6.667C4 5.2 5.2 4 6.667 4zm16.946 8.44c.64-.533 1.387-1.173 1.72-1.88-.547.28-1.2.453-1.92.547.667-.48 1.213-1.107 1.493-1.96-.693.373-1.4.693-2.28.853-2.067-2.493-7.013-.467-6.133 3.267-3.48-.213-5.6-1.787-7.36-3.72-1 1.627-.133 4.093 1.053 4.773-.613-.04-1.08-.227-1.52-.44.053 2.053 1.187 3.04 2.773 3.573a4.47 4.47 0 0 1-1.52.04c.493 1.427 1.52 2.32 3.28 2.507-1.2 1.013-3.413 1.72-5.2 1.44 1.533.973 3.28 1.747 5.707 1.64 5.88-.267 9.813-4.48 9.907-10.64z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="twitter">
        <path
            d="M29.947 8a11.423 11.423 0 0 1-3.28.92 5.738 5.738 0 0 0 2.507-3.173 11.52 11.52 0 0 1-3.627 1.4C24.494 6 23.014 5.334 21.334 5.334c-3.133 0-5.693 2.56-5.693 5.72 0 .453.053.893.147 1.307A16.261 16.261 0 0 1 4.001 6.388a5.663 5.663 0 0 0-.773 2.867c0 1.987 1 3.747 2.547 4.747-.947 0-1.827-.267-2.6-.667v.04a5.724 5.724 0 0 0 4.587 5.613 5.644 5.644 0 0 1-2.574.093c.72 2.253 2.813 3.933 5.333 3.973-1.947 1.547-4.413 2.453-7.107 2.453-.453 0-.907-.027-1.36-.08A16.19 16.19 0 0 0 10.827 28c10.507 0 16.28-8.72 16.28-16.28 0-.253 0-.493-.013-.747A11.42 11.42 0 0 0 29.947 8z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="white-balance-sunny">
        <path
            d="M4.733 24.72l1.88 1.88 2.4-2.387L7.12 22.32zm9.934 5.213h2.667V26h-2.667zM16 7.333c-4.413 0-8 3.587-8 8s3.587 8 8 8 8-3.587 8-8c0-4.427-3.587-8-8-8zm10.667 9.334h4V14h-4zm-3.68 7.546l2.4 2.387 1.88-1.88-2.387-2.4zm4.28-18.266l-1.88-1.88-2.4 2.387 1.893 1.893zM17.333.733h-2.667v3.933h2.667zM5.333 14h-4v2.667h4zm3.68-7.547l-2.4-2.387-1.88 1.88 2.387 2.4 1.893-1.893z">
        </path>
    </symbol>
    <symbol xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32" id="window-close">
        <path
            d="M17.947 16l7.387 7.387v1.947h-1.947L16 17.947l-7.387 7.387H6.666v-1.947L14.053 16 6.666 8.613V6.666h1.947L16 14.053l7.387-7.387h1.947v1.947L17.947 16z">
        </path>
    </symbol>
</svg>
    <div class="site">
        <header class="site-header container">
    <div class="header-left">
        <a class="logo" href="https://www.aiweirdness.com">
                <img class="logo-image" src="https://www.aiweirdness.com/content/images/2021/03/ai_weirdness_with_neural_net_box.png" alt="AI Weirdness">
        </a>
    </div>
        <nav class="main-nav hidden-xs hidden-sm hidden-md">
                <a class="menu-item menu-item-home"
        href="https://www.aiweirdness.com/">Home</a>
    <a class="menu-item menu-item-ai-weirdness-book-you-look-like-a-thing"
        href="https://youlooklikeathing.com">AI Weirdness Book: You look like a thing</a>
    <a class="menu-item menu-item-about-janelle"
        href="https://janelleshane.com">About Janelle</a>
    <a class="menu-item menu-item-subscribe"
        href="https://www.aiweirdness.com/subscribe/">Subscribe</a>

            <button class="button-icon menu-item-button js-modal" data-modal="search" aria-label="Search">
                <svg class="icon">
                    <use xlink:href="#magnify"></use>
                </svg>
            </button>
        </nav>

        <button class="button-icon hidden-lg hidden-xl js-modal" data-modal="search" aria-label="Search">
            <svg class="icon">
                <use xlink:href="#magnify"></use>
            </svg>
        </button>
        <div class="burger hidden-lg hidden-xl">
            <div class="burger-bar"></div>
            <div class="burger-bar"></div>
        </div>

        <div class="mobile-menu hidden-lg hidden-xl">
            <div class="container">
                <nav class="mobile-nav">
                        <a class="menu-item menu-item-home"
        href="https://www.aiweirdness.com/">Home</a>
    <a class="menu-item menu-item-ai-weirdness-book-you-look-like-a-thing"
        href="https://youlooklikeathing.com">AI Weirdness Book: You look like a thing</a>
    <a class="menu-item menu-item-about-janelle"
        href="https://janelleshane.com">About Janelle</a>
    <a class="menu-item menu-item-subscribe"
        href="https://www.aiweirdness.com/subscribe/">Subscribe</a>

                        <button class="button-text menu-item members-login" data-portal="signin">Login</button>
                        <button class="button-text menu-item menu-item-cta members-subscribe" data-portal="signup">Subscribe</button>
                </nav>
            </div>
        </div>
    <div class="header-right hidden-xs hidden-sm hidden-md">
            <button class="button-text menu-item members-login" data-portal="signin">Login</button>
            <button class="button-text menu-item menu-item-cta members-subscribe" data-portal="signup">Subscribe</button>
    </div>
</header>

        <header class="sticky">
            <div class="sticky-title">When algorithms surprise us</div>
            <button class="button-icon sticky-toc-button" aria-label="Table of Contents">
                <svg class="icon">
                    <use xlink:href="#table-of-contents"></use>
                </svg>
                <div class="sticky-toc"></div>
            </button>
            <div class="sticky-track">
                <div class="sticky-progress"></div>
            </div>
        </header>
        <div class="site-content">
            
<div class="content-area">
    <main class="site-main">
            <article class="single post tag-machine-learning tag-evolutionary-algorithms tag-evolution tag-neural-networks tag-the-matrix tag-hash-tumblr tag-hash-substacktumblrduplicate">
    <header class="single-header kg-canvas">
            <div class="single-meta">
                <span class="single-meta-item single-meta-date">
                    <time datetime="2018-04-13">
                        Apr 13, 2018
                    </time>
                </span>
                <span class="single-meta-item single-meta-length">
                    5 min read
                </span>
                    <span class="single-meta-item single-meta-tag">
                        <a class="post-tag post-tag-machine-learning" href="/tag/machine-learning/">
                            machine learning
                        </a>
                    </span>
            </div>
        <h1 class="single-title">When algorithms surprise us</h1>
                <div class="single-media kg-width-wide u-placeholder horizontal">
                    <img class="lazyload u-object-fit" data-srcset="/content/images/size/w400/image/fetch/w_1200-c_limit-f_jpg-q_auto:good-fl_progressive:steep/https-3A-2F-2Fbucketeer-e05bbc84-baa3-437e-9518-adb32be77984.s3.amazonaws.com-2Fpublic-2Fimages-2F25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364 400w,
/content/images/size/w750/image/fetch/w_1200-c_limit-f_jpg-q_auto:good-fl_progressive:steep/https-3A-2F-2Fbucketeer-e05bbc84-baa3-437e-9518-adb32be77984.s3.amazonaws.com-2Fpublic-2Fimages-2F25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364 750w,
/content/images/size/w960/image/fetch/w_1200-c_limit-f_jpg-q_auto:good-fl_progressive:steep/https-3A-2F-2Fbucketeer-e05bbc84-baa3-437e-9518-adb32be77984.s3.amazonaws.com-2Fpublic-2Fimages-2F25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364 960w,
/content/images/size/w1140/image/fetch/w_1200-c_limit-f_jpg-q_auto:good-fl_progressive:steep/https-3A-2F-2Fbucketeer-e05bbc84-baa3-437e-9518-adb32be77984.s3.amazonaws.com-2Fpublic-2Fimages-2F25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364 1140w"
                        data-sizes="auto" src="/content/images/size/w960/image/fetch/w_1200-c_limit-f_jpg-q_auto:good-fl_progressive:steep/https-3A-2F-2Fbucketeer-e05bbc84-baa3-437e-9518-adb32be77984.s3.amazonaws.com-2Fpublic-2Fimages-2F25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364"
                        srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="
                        alt="When algorithms surprise us">
                </div>
    </header>
    <div class="single-content kg-canvas u-text-format">
        <p>Machine learning algorithms are not like other computer programs. In the usual sort of programming, a human programmer tells the computer exactly what to do. In machine learning, the human programmer merely gives the algorithm the problem to be solved, and through trial-and-error the algorithm has to figure out how to solve it.</p><p>This often works really well - machine learning algorithms are widely used for facial recognition, language translation, financial modeling, image recognition, and ad delivery. If you’ve been online today, you’ve probably interacted with a machine learning algorithm.</p><p>But it doesn’t always work well. Sometimes the programmer will think the algorithm is doing really well, only to look closer and discover it’s solved an entirely different problem from the one the programmer intended. For example, I looked earlier at an image recognition algorithm that was supposed to recognize sheep but learned to recognize grass instead, and <a href="http://aiweirdness.com/post/171451900302/do-neural-nets-dream-of-electric-sheep">kept labeling empty green fields as containing sheep</a>.</p><figure class="kg-card kg-image-card"><img src="https://www.aiweirdness.com/content/images/public/images/25adb34e-ce9f-4112-8b99-030f45224b2b_2000x1364.jpg" class="kg-image" alt="image" loading="lazy" title="image"></figure><p>When machine learning algorithms solve problems in unexpected ways, programmers find them, okay yes, annoying sometimes, but often purely delightful.</p><p>So delightful, in fact, that<a href="https://arxiv.org/pdf/1803.03453.pdf"> in 2018 a group of researchers wrote a fascinating paper</a> that collected dozens of anecdotes that “elicited surprise and wonder from the researchers studying them”. <a href="https://arxiv.org/pdf/1803.03453.pdf">The paper</a> is well worth reading, as are the original references, but here are several of my favorite examples.</p><p><strong>Bending the rules to win</strong></p><p>First, there’s a long tradition of using simulated creatures to study how different forms of locomotion might have evolved, or to come up with new ways for robots to walk.</p><p><strong>Why walk when you can flop? </strong>In one example, a simulated robot was supposed to evolve to travel as quickly as possible. But rather than evolve legs, it simply assembled itself into a tall tower, then fell over. Some of these robots even learned to turn their falling motion into a somersault, adding extra distance.</p><figure class="kg-card kg-image-card"><img src="https://www.aiweirdness.com/content/images/public/images/42e57434-cb8a-4432-8645-b4b93511ed33_2120x858.png" class="kg-image" alt="image" loading="lazy" title="image"></figure><p>[Image: Robot is simply a tower that falls over.]</p><p><strong>Why jump when you can can-can? </strong>Another set of simulated robots were supposed to evolve into a form that could jump. But the programmer had originally defined jumping height as the height of the tallest block so - once again - the robots evolved to be very tall. The programmer tried to solve this by defining jumping height as the height of the block that was originally the *lowest*. In response, the robot developed a long skinny leg that it could kick high into the air in a sort of robot can-can.</p><figure class="kg-card kg-image-card"><img src="https://www.aiweirdness.com/content/images/public/images/2e18d4e3-105e-42bd-b7b8-9bb027765da9_1880x650.png" class="kg-image" alt="image" loading="lazy" title="image"></figure><p>[Image: Tall robot flinging a leg into the air instead of jumping]</p><p><strong>Hacking the Matrix for superpowers</strong></p><p>Potential energy is not the only energy source these simulated robots learned to exploit. It turns out that, like in real life, if an energy source is available, something will evolve to use it.</p><p><strong>Floating-point rounding errors as an energy source: </strong>In one simulation, robots learned that small rounding errors in the math that calculated forces meant that they got a tiny bit of extra energy with motion. They learned to twitch rapidly, generating lots of free energy that they could harness. The programmer noticed the problem when the robots started swimming extraordinarily fast.</p><p><strong>Harvesting energy from crashing into the floor: </strong>Another simulation had some problems with its collision detection math that robots learned to use. If they managed to glitch themselves into the floor (they first learned to manipulate time to make this possible), the collision detection would realize they weren’t supposed to be in the floor and would shoot them upward. The robots learned to vibrate rapidly against the floor, colliding repeatedly with it to generate extra energy.</p><figure class="kg-card kg-image-card"><img src="https://www.aiweirdness.com/content/images/public/images/d936a527-4216-4abc-95d2-b83b25e2b7cf_2804x292.png" class="kg-image" alt="image" loading="lazy" title="image"></figure><p>[Image: robot moving by vibrating into the floor]</p><p><strong>Clap to fly: </strong>In another simulation, jumping bots learned to harness a different collision-detection bug that would propel them high into the air every time they crashed two of their own body parts together. Commercial flight would look a lot different if this worked in real life.</p><p><strong>Discovering secret moves: </strong>Computer game-playing algorithms are really good at discovering the kind of Matrix glitches that humans usually learn to exploit for speed-running. An algorithm playing the old Atari game Q*bert discovered a previously-unknown bug where it could perform a very specific series of moves at the end of one level and instead of moving to the next level, all the platforms would begin blinking rapidly and the player would start accumulating huge numbers of points.</p><p>A Doom-playing algorithm also figured out a special combination of movements that would stop enemies from firing fireballs - but it only works in the algorithm’s hallucinated dream-version of Doom. <a href="https://worldmodels.github.io/">Delightfully, you can play the dream-version here</a></p><figure class="kg-card kg-image-card"><img src="https://www.aiweirdness.com/content/images/public/images/e1706b47-cc50-49e8-aa21-5be893c41e92_1570x416.png" class="kg-image" alt="image" loading="lazy" title="image"></figure><p>[Image: Q*bert player is accumulating a suspicious number of points, considering that it’s not doing much of anything]</p><p><strong>Shooting the moon:</strong> In one of the more chilling examples, there was an algorithm that was supposed to figure out how to apply a minimum force to a plane landing on an aircraft carrier. Instead, it discovered that if it applied a *huge* force, it would overflow the program’s memory and would register instead as a very *small* force. The pilot would die but, hey, perfect score.<br></p><p><strong>Destructive problem-solving</strong></p><p>Something as apparently benign as a list-sorting algorithm could also solve problems in rather innocently sinister ways.</p><p><strong>Well, it’s not </strong><em><strong>un</strong></em><strong>sorted: </strong>For example, there was an algorithm that was supposed to sort a list of numbers. Instead, it learned to delete the list, so that it was no longer technically unsorted.</p><p><strong>Solving the </strong><em><strong>Kobayashi Maru</strong></em><strong> test:</strong><em><strong> </strong></em>Another algorithm was supposed to minimize the difference between its own answers and the correct answers. It found where the answers were stored and deleted them, so it would get a perfect score.</p><p><strong>How to win at tic-tac-toe: </strong>In another beautiful example, in 1997 some programmers built algorithms that could play tic-tac-toe remotely against each other on an infinitely large board. One programmer, rather than designing their algorithm’s strategy, let it evolve its own approach. Surprisingly, the algorithm suddenly began winning all its games. It turned out that the algorithm’s strategy was to place its move very, very far away, so that when its opponent’s computer tried to simulate the new greatly-expanded board, the huge gameboard would cause it to run out of memory and crash, forfeiting the game.</p><p><strong>In conclusion</strong></p><p>When machine learning solves problems, it can come up with solutions that range from clever to downright uncanny.</p><p>Biological evolution works this way, too - as any biologist will tell you, living organisms find the strangest solutions to problems, and the strangest energy sources to exploit. Sometimes I think the surest sign that we’re not living in a computer simulation is that if we were, some microbe would have learned to exploit its flaws.</p><p>So as programmers we have to be very very careful that our algorithms are solving the problems that we meant for them to solve, not exploiting shortcuts. If there’s another, easier route toward solving a given problem, machine learning will likely find it.</p><p>Fortunately for us, “kill all humans” is really really hard. If “bake an unbelievably delicious cake” also solves the problem and is easier than “kill all humans”, then machine learning will go with cake.</p><p><strong>Mailing list plug</strong></p><p>If you become an AI Weirdness supporter, there will be cake!</p><p><a href="#/portal/signup">Subscribe now</a></p>
    </div>
        <footer class="single-footer container medium">
            <div class="single-footer-left">
                    <div class="navigation navigation-previous">
                        <a class="navigation-link" href="/neural-network-named-tomatoes-you-18-04-05/"
                            aria-label="Previous post">
                            <svg class="icon navigation-icon">
                                <use xlink:href="#arrow-left"></use>
                            </svg>
                        </a>
                    </div>
            </div>
            <div class="single-footer-middle">
                <div class="single-footer-top">
                    <h3 class="single-footer-title">Published by:</h3>
                    <div class="author-list">
                            <div
                                class="author-image-placeholder u-placeholder square">
                                <a href="/author/ai/" title="Janelle Shane">
                                    <img class="author-image lazyload u-object-fit"
                                        data-srcset="/content/images/size/w150/2021/03/neural_net_box_default_square-01.png"
                                        src="/content/images/size/w150/2021/03/neural_net_box_default_square-01.png"
                                        srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="
                                        alt="Janelle Shane">
                                </a>
                            </div>
                    </div>
                </div>
                <div class="single-footer-bottom">
                    <div class="share">
                        <a class="share-link share-link-facebook"
                            href="https://www.facebook.com/sharer.php?u=https://www.aiweirdness.com/when-algorithms-surprise-us-18-04-13/"
                            target="_blank" rel="noopener noreferrer">
                            <svg class="icon icon-facebook">
                                <use xlink:href="#facebook"></use>
                            </svg>
                            Share
                        </a>
                        <a class="share-link share-link-twitter"
                            href="https://twitter.com/intent/tweet?url=https://www.aiweirdness.com/when-algorithms-surprise-us-18-04-13/&text=When%20algorithms%20surprise%20us"
                            target="_blank" rel="noopener noreferrer">
                            <svg class="icon icon-twitter">
                                <use xlink:href="#twitter"></use>
                            </svg>
                            Tweet
                        </a>
                    </div>
                </div>
            </div>
            <div class="single-footer-right">
                    <div class="navigation navigation-next">
                        <a class="navigation-link" href="/skyknit-when-knitters-teamed-up-with-18-04-19/"
                            aria-label="Next post">
                            <svg class="icon navigation-icon">
                                <use xlink:href="#arrow-right"></use>
                            </svg>
                        </a>
                    </div>
            </div>
        </footer>
</article>                    <section class="related-wrapper">
            <div class="container medium">
                <h3 class="related-title">You might also like...</h3>
                <div class="related-feed">
                        <article class="feed post featured">
    <div class="feed-calendar">
        <div class="feed-calendar-month">
            Sep
        </div>
        <div class="feed-calendar-day">
            03
        </div>
    </div>
    <h2 class="feed-title">AI is based on math so it is correct</h2>
    <div class="feed-right">
        <svg class="icon feed-visibility feed-visibility-public">
            <use xlink:href="#star"></use>
        </svg>
        <div class="feed-length">
            3 min read
        </div>
    </div>
    <svg class="icon feed-icon">
        <use xlink:href="#chevron-right"></use>
    </svg>
    <a class="u-permalink" href="/clip-backpropagation/" aria-label="AI is based on math so it is correct"></a>
</article>                        <article class="feed post">
    <div class="feed-calendar">
        <div class="feed-calendar-month">
            Aug
        </div>
        <div class="feed-calendar-day">
            27
        </div>
    </div>
    <h2 class="feed-title">Better than the unicorn cakes</h2>
    <div class="feed-right">
        <svg class="icon feed-visibility feed-visibility-paid">
            <use xlink:href="#star"></use>
        </svg>
        <div class="feed-length">
            1 min read
        </div>
    </div>
    <svg class="icon feed-icon">
        <use xlink:href="#chevron-right"></use>
    </svg>
    <a class="u-permalink" href="/better-than-the-unicorn-cakes/" aria-label="Better than the unicorn cakes"></a>
</article>                        <article class="feed post featured">
    <div class="feed-calendar">
        <div class="feed-calendar-month">
            Aug
        </div>
        <div class="feed-calendar-day">
            27
        </div>
    </div>
    <h2 class="feed-title">In search of a unicorn cake</h2>
    <div class="feed-right">
        <svg class="icon feed-visibility feed-visibility-public">
            <use xlink:href="#star"></use>
        </svg>
        <div class="feed-length">
            4 min read
        </div>
    </div>
    <svg class="icon feed-icon">
        <use xlink:href="#chevron-right"></use>
    </svg>
    <a class="u-permalink" href="/unicorn-cakes/" aria-label="In search of a unicorn cake"></a>
</article>                        <article class="feed post no-image">
    <div class="feed-calendar">
        <div class="feed-calendar-month">
            Aug
        </div>
        <div class="feed-calendar-day">
            18
        </div>
    </div>
    <h2 class="feed-title">More AI cake fails</h2>
    <div class="feed-right">
        <svg class="icon feed-visibility feed-visibility-paid">
            <use xlink:href="#star"></use>
        </svg>
        <div class="feed-length">
            1 min read
        </div>
    </div>
    <svg class="icon feed-icon">
        <use xlink:href="#chevron-right"></use>
    </svg>
    <a class="u-permalink" href="/more-ai-cake-fails/" aria-label="More AI cake fails"></a>
</article>                        <article class="feed post featured">
    <div class="feed-calendar">
        <div class="feed-calendar-month">
            Aug
        </div>
        <div class="feed-calendar-day">
            18
        </div>
    </div>
    <h2 class="feed-title">AI cake fails</h2>
    <div class="feed-right">
        <svg class="icon feed-visibility feed-visibility-public">
            <use xlink:href="#star"></use>
        </svg>
        <div class="feed-length">
            5 min read
        </div>
    </div>
    <svg class="icon feed-icon">
        <use xlink:href="#chevron-right"></use>
    </svg>
    <a class="u-permalink" href="/ai-cake-fails/" aria-label="AI cake fails"></a>
</article>                </div>
            </div>
        </section>
                </main>
</div>
        </div>
        <footer class="site-footer container">
    <div class="social">
            <a class="social-item social-item-facebook"
                href="https://www.facebook.com/ghost" target="_blank"
                rel="noopener noreferrer" aria-label="Facebook">
                <svg class="icon">
                    <use xlink:href="#facebook-box"></use>
                </svg>
            </a>
            <a class="social-item social-item-twitter"
                href="https://twitter.com/ghost" target="_blank"
                rel="noopener noreferrer" aria-label="Twitter">
                <svg class="icon">
                    <use xlink:href="#twitter-box"></use>
                </svg>
            </a>
        <a class="social-item social-item-rss"
            href="https://feedly.com/i/subscription/feed/https://www.aiweirdness.com/rss/"
            target="_blank" rel="noopener noreferrer" aria-label="RSS">
            <svg class="icon">
                <use xlink:href="#rss-box"></use>
            </svg>
        </a>
    </div>

    <div class="copyright">
        Powered by <a href="https://ghost.org/" target="_blank"
            rel="noopener noreferrer">Ghost</a>
    </div>

    <nav class="footer-nav">
            <a class="menu-item menu-item-contact"
        href="https://www.janelleshane.com/contact">Contact</a>

        <a class="menu-item js-theme" href="#" data-system="System theme" data-dark="Dark theme" data-light="Light theme">
            <svg class="icon theme-icon theme-icon-system">
                <use xlink:href="#circle-half-full"></use>
            </svg>
            <svg class="icon theme-icon theme-icon-dark">
                <use xlink:href="#brightness-2"></use>
            </svg>
            <svg class="icon theme-icon theme-icon-light">
                <use xlink:href="#white-balance-sunny"></use>
            </svg>
            <span class="theme-text">System theme</span>
        </a>
    </nav>
</footer>        <div class="modal-overlay">
    <div class="modal modal-search">
        <div class="form-wrapper">
            <input class="modal-input search-input" type="search" placeholder="Enter keyword...">
            <button class="form-button search-button" aria-label="Search">
                <svg class="icon icon-search">
                    <use xlink:href="#magnify"></use>
                </svg>
                <svg class="icon icon-close">
                    <use xlink:href="#window-close"></use>
                </svg>
            </button>
        </div>
                <div class="popular-wrapper">
                    <h4 class="popular-title">Popular tags</h4>
                    <div class="popular-feed">
                            <a class="popular" href="/tag/newsletter/">Newsletter</a>
                            <a class="popular" href="/tag/neural-networks/">neural networks</a>
                    </div>
                </div>
        <div class="search-result"></div>
    </div>
    <button class="button-icon modal-close" aria-label="Close">
        <svg class="icon icon-close">
            <use xlink:href="#window-close"></use>
        </svg>
    </button>
</div>        <!-- Root element of PhotoSwipe. Must have class pswp. -->
<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">
    <!-- Background of PhotoSwipe.
        It's a separate element as animating opacity is faster than rgba(). -->
    <div class="pswp__bg"></div>

    <!-- Slides wrapper with overflow:hidden. -->
    <div class="pswp__scroll-wrap">
        <!-- Container that holds slides.
          PhotoSwipe keeps only 3 of them in the DOM to save memory.
          Don't modify these 3 pswp__item elements, data is added later on. -->
        <div class="pswp__container">
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
        </div>

        <!-- Default (PhotoSwipeUI_Default) interface on top of sliding area. Can be changed. -->
        <div class="pswp__ui pswp__ui--hidden">
            <div class="pswp__top-bar">
                <!--  Controls are self-explanatory. Order can be changed. -->
                <div class="pswp__counter"></div>

                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
                <button class="pswp__button pswp__button--share" title="Share"></button>
                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>

                <!-- Preloader demo https://codepen.io/dimsemenov/pen/yyBWoR -->
                <!-- element will get class pswp__preloader--active when preloader is running -->
                <div class="pswp__preloader">
                    <div class="pswp__preloader__icn">
                        <div class="pswp__preloader__cut">
                            <div class="pswp__preloader__donut"></div>
                        </div>
                    </div>
                </div>
            </div>

            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
                <div class="pswp__share-tooltip"></div>
            </div>

            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)"></button>
            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)"></button>

            <div class="pswp__caption">
                <div class="pswp__caption__center"></div>
            </div>
        </div>
    </div>
</div>    </div>

    <script
        src="https://code.jquery.com/jquery-3.5.1.min.js"
        integrity="sha256-9/aliU8dGd2tb6OSsuzixeV4y/faTqgFtohetphbbj0="
        crossorigin="anonymous">
    </script>
    <script src="/assets/built/main.min.js?v=cd27d1f60a"></script>

    
</body>

</html>